December 06, 2013

Lab 03: OSPF Area Types

Configure OSPF in AREA 0:

router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0

R3 is DR and R4 is BDR. State between R1 and R2 is 2WAY becase they don't send the updates to each other. They send the updates only to DR and BDR.

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   2WAY/DROTHER    00:00:34    10.0.0.1        Ethernet2/1
3.3.3.3           1   FULL/BDR        00:00:38    10.0.0.3        Ethernet2/1
4.4.4.4           1   FULL/DR         00:00:33    10.0.0.4        Ethernet2/1

After configuration of AREA 3:

R7#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     67.0.0.0/30 is subnetted, 1 subnets
C       67.0.0.0 is directly connected, Ethernet2/1
     37.0.0.0/30 is subnetted, 1 subnets
C       37.0.0.0 is directly connected, Ethernet2/0
     10.0.0.0/24 is subnetted, 1 subnets
O IA    10.0.0.0 [110/20] via 37.0.0.1, 00:00:24, Ethernet2/0

Let's configure AREA 2 as stub:

router ospf 1
 area 2 stub
 network 46.0.0.0 0.0.0.3 area 2

When RIP is configured between R3 and R8, 8.8.8.8/32 network is in R3's routing table:

R3#show ip route | include 8.8.8.8
R       8.8.8.8 [120/1] via 38.0.0.2, 00:00:08, Serial0/1

Redistribute RIP routes into OSPF on R3:

router ospf 1
 redistribute rip metric 2000 metric-type 2 subnets

8.8.8.8/32 network is seen on R4:

R4#show ip route | include 8.8.8.8
O E2    8.8.8.8 [110/2000] via 10.0.0.3, 00:00:29, Ethernet2/1

There is only an OSPF default-route on R6 instead of 8.8.8.8/32 because external routes are not allowed in a stub area.

R6#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 46.0.0.1 to network 0.0.0.0

     37.0.0.0/30 is subnetted, 1 subnets
O IA    37.0.0.0 [110/30] via 46.0.0.1, 00:54:41, Ethernet2/0
     25.0.0.0/30 is subnetted, 1 subnets
O IA    25.0.0.0 [110/30] via 46.0.0.1, 00:15:15, Ethernet2/0
     10.0.0.0/24 is subnetted, 1 subnets
O IA    10.0.0.0 [110/20] via 46.0.0.1, 00:54:41, Ethernet2/0
     46.0.0.0/30 is subnetted, 1 subnets
C       46.0.0.0 is directly connected, Ethernet2/0
O*IA 0.0.0.0/0 [110/11] via 46.0.0.1, 00:54:41, Ethernet2/0

Configure AREA 1 as totally stub:

R2#show running-config | section ospf
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 1 stub no-summary
 network 10.0.0.0 0.0.0.255 area 0
 network 25.0.0.0 0.0.0.3 area 1

R5#show running-config | section ospf
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 area 1 stub
 network 25.0.0.0 0.0.0.3 area 1

Inter-area and external routes are not allowed in a totally stubby area, so only an OSPF default-route is seen on R5:

R5#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 25.0.0.1 to network 0.0.0.0

     25.0.0.0/30 is subnetted, 1 subnets
C       25.0.0.0 is directly connected, Ethernet2/0
O*IA 0.0.0.0/0 [110/11] via 25.0.0.1, 00:01:36, Ethernet2/0

# DOWNLOAD LAB 03 GNS3 FILE